Garmin Montana 610 - Losing Satellite Signal

Post Reply
User avatar
Isfand
Intermediate
Intermediate
Posts: 40
Joined: Thu Feb 01, 2018 7:35 pm
Location: Mirdif, Dubai
Has thanked: 259 times
Been thanked: 121 times

Sun Jul 07, 2019 4:19 pm

Dear Almosters,

Has anybody had an issue with the Garmin Montana 610 losing signal?

I first noticed this during Grand Iftar where I lost all signal in the dark after wanting to return back from the road to the Almost Camp. Had to rely on Google maps that time.
It was fine the next day. I had a chat with Bu Salem regarding this and was advised to update my device and check the connections of other devices in the car as something might be interfering.

I disconnected the GPS and kept it aside until recently when I connected it again in the car and its still keeps losing signal. On the highway - In the desert - Out of the car/inside the car.

Thanks in advance.
User avatar
caprihorse
Golden Member
Golden Member
Posts: 8
Joined: Tue Nov 16, 2010 1:23 am
Location: Bratislava, Slovakia
Has thanked: 3 times
Been thanked: 3 times
Contact:

Mon Jul 08, 2019 9:54 am

Maybe the device is faulty. Speak to the shop.
User avatar
Isfand
Intermediate
Intermediate
Posts: 40
Joined: Thu Feb 01, 2018 7:35 pm
Location: Mirdif, Dubai
Has thanked: 259 times
Been thanked: 121 times

Fri Jul 12, 2019 9:43 am

Gave it for warranty repair/check.

As of now 2 other members have reported the exact same issue. @Rooies & @Bu Zayed
It seems it could be a software issue but waiting for resolution
caprihorse wrote:
Mon Jul 08, 2019 9:54 am
Maybe the device is faulty. Speak to the shop.
Post Reply