Garmin Montana 650

khshareef
Club Member
Club Member
Posts: 0
Joined: Sun Feb 26, 2012 3:17 pm

Mon Feb 03, 2014 6:05 pm

Gents,

I need some suggestion on Garmin Montana 650.

I have been using this unit since 1 year now with unlocked maps (not original) and it was fine with map source and I was happy man.

I have now upgraded the maps to Original one by making payment and downloaded from Garmin website including Garmin Bird eye subscription which was fine for 2 days and now made my nights miserable as spending long hours on this to understand.
Since 2 days whenever I switch on the gps there is an error as "Cant authenticate maps. Contact content seller for help". When u click ok, it is fine and we are able to navigate.
Secondly when I try to connect my gps with garmin base camp through through usb, I am getting the below errors.
"There was a problem communicating with Garmin Device"
and
"There are problem communicating with Montana 650 unit id.xxxxxxx"

I have also made a complaint in Garmin website and awaiting to hear from them too as their response time is min. 3 working days from query date.

In the mean time, If any of you has come across such errors pls guide me what has to be done to rectify this. thanks..
User avatar
caprihorse
Golden Member
Golden Member
Posts: 9
Joined: Tue Nov 16, 2010 1:23 am
Location: Bratislava, Slovakia
Has thanked: 2 times
Been thanked: 4 times
Contact:

Mon Feb 03, 2014 7:11 pm

khshareef;32717 wrote:Gents,

I need some suggestion on Garmin Montana 650.

I have been using this unit since 1 year now with unlocked maps (not original) and it was fine with map source and I was happy man.

I have now upgraded the maps to Original one by making payment and downloaded from Garmin website including Garmin Bird eye subscription which was fine for 2 days and now made my nights miserable as spending long hours on this to understand.
Since 2 days whenever I switch on the gps there is an error as "Cant authenticate maps. Contact content seller for help". When u click ok, it is fine and we are able to navigate.
Secondly when I try to connect my gps with garmin base camp through through usb, I am getting the below errors.
"There was a problem communicating with Garmin Device"
and
"There are problem communicating with Montana 650 unit id.xxxxxxx"

I have also made a complaint in Garmin website and awaiting to hear from them too as their response time is min. 3 working days from query date.

In the mean time, If any of you has come across such errors pls guide me what has to be done to rectify this. thanks..
A bit searching would help you to solve your problem, you are not alone...

Read more here - http://www.almost4x4.com/vb/showthread. ... amp-Tricks

With your second problem, try to plug USB cable in a different port are reinstall USB driver.
khshareef
Club Member
Club Member
Posts: 0
Joined: Sun Feb 26, 2012 3:17 pm

Tue Feb 04, 2014 11:36 am

Thanks. I have gone through the whole thread and did not find answer related to the queries above. Looks like none has come across this issue and let me wait for the answer from garmin customer service.
User avatar
caprihorse
Golden Member
Golden Member
Posts: 9
Joined: Tue Nov 16, 2010 1:23 am
Location: Bratislava, Slovakia
Has thanked: 2 times
Been thanked: 4 times
Contact:

Tue Feb 04, 2014 11:45 am

khshareef;32729 wrote:Thanks. I have gone through the whole thread and did not find answer related to the queries above. Looks like none has come across this issue and let me wait for the answer from garmin customer service.
I had the same issue, at least your question 1. You did upgrade your Montana to Version 5.60 and this is your problem. You need to downgrade to Version 5.40, as described in my post #71 (http://www.almost4x4.com/vb/showthread. ... amp-Tricks) and your problem will be solved.
Adnan
Advance
Advance
Posts: 0
Joined: Mon Feb 27, 2012 2:44 pm

Tue Feb 04, 2014 10:19 pm

Don't worry brother, and make it short cut and call the following guy which he is the regional Garmin maintenance engineer,Mr. Jalal 055 6162206 and he will give you the appropriate solution.
User avatar
desert_hawk
Intermediate
Intermediate
Posts: 0
Joined: Mon Jan 23, 2012 11:54 am

Sun Mar 09, 2014 10:46 pm

any update on the solution? curious to know?
User avatar
alshamsi_m
Founder
Founder
Posts: 378
Joined: Fri Aug 10, 2007 8:29 am
Location: Al Hamriyah
Has thanked: 613 times
Been thanked: 827 times
Contact:

Sun Mar 09, 2014 11:10 pm

desert_hawk;33733 wrote:any update on the solution? curious to know?
The bug has been fixed with 5.7 ... So just go ahead and upgrade
Adventurous League of Mountains, Oceans and Sand Thrills
User avatar
caprihorse
Golden Member
Golden Member
Posts: 9
Joined: Tue Nov 16, 2010 1:23 am
Location: Bratislava, Slovakia
Has thanked: 2 times
Been thanked: 4 times
Contact:

Mon Mar 10, 2014 9:13 am

desert_hawk;33733 wrote:any update on the solution? curious to know?
We have full thread dedicated to Montana here - http://www.almost4x4.com/vb/showthread. ... amp-Tricks

and to BaseCamp here - http://www.almost4x4.com/vb/showthread. ... are-Review
khshareef
Club Member
Club Member
Posts: 0
Joined: Sun Feb 26, 2012 3:17 pm

Sun Mar 16, 2014 12:52 pm

Adnan;32757 wrote:Don't worry brother, and make it short cut and call the following guy which he is the regional Garmin maintenance engineer,Mr. Jalal 055 6162206 and he will give you the appropriate solution.
THANKS DEar Adnan for your support. Yesterday I met Mr. Jalal and he was helpful in fixing the bug. Now the base camp is working fine for me. Thanks once again.
bijubs
Newbie
Newbie
Posts: 0
Joined: Mon Mar 19, 2012 7:14 pm

Wed Aug 20, 2014 2:25 pm

khshareef;33952 wrote:THANKS DEar Adnan for your support. Yesterday I met Mr. Jalal and he was helpful in fixing the bug. Now the base camp is working fine for me. Thanks once again.
Woww... above thread find quite interesting after get solved ... grate Almostersss, keep going the sprit
Post Reply